Marginalia Search Engine Software Documentation

1.2 Software Requirements

The software requirements for running the Marginalia Search Engine are:

  • Linux, probably doesn’t matter which distro, the instructions assume something Debian or Ubuntu-like. If you’re running something else, you’re probably smart enough to figure it out.
  • Docker (install guides)
  • Docker Compose (install guides
  • Java 22 (use sdkman to install)
Last updated on 16 Jan 2024
Published on 16 Jan 2024